Close

AngularJS : Error ng-controller en angular 1.3 o posterior

Hace unos días me volví a meter a AngularJS con el Framework para app móviles “ionic“, por lo cual pues en mi proyecto se importa la librería de angular Más Reciente la cual fue 1.3.13 al estar probando vi que desde esta versión tiene conflictos al definir nuestro ng-controller en el html.

Puedes ver en la siguiente imagen mi esquema de trabajo:

desarrollo_hidroclaido_error_ngcontroller

 

Después de investigar un poco por internet encontré que no se puede declarar un constructor global  y usarlo como nuestro ng-controller como al menos yo lo solía hacer antes, lo cual esto nos obliga a declararlo dentro de nuestro modulo principal.

Muestro el código como lo tenía antes:

Vista

Controlador

Y Ahora lo Tengo Asi:

Vista

Queda Igual

Controlador

 Conclusión: Eso pasa por no estar actualizado en AngularJS

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.